Hide chapters

Swift Apprentice: Beyond the Basics

First Edition · iOS 16 · Swift 5.8 · Xcode 14.3

Section I: Beyond the Basics

Section 1: 13 chapters
Show chapters Hide chapters

To follow along with the tutorials in this book, you’ll need the following:

  • A Mac running macOS Ventura 13.0 or later. with the latest point release and security patches installed. This is so you can install the latest version of the required development tool: Xcode.
  • Xcode 14.3 or later. Xcode is the main development tool for writing code in Swift. You need Xcode 14.3 at a minimum, since that version includes Swift 5.8 Xcode playgrounds. You can download the latest version of Xcode for free from the Mac App Store, here:

If you haven’t installed the latest version of Xcode, be sure to do that before continuing with the book. The code covered in this book depends on Swift 5.8 and Xcode 14.3 — you may get lost if you try to work with an older version or work outside the playground environment that this book assumes.

Have a technical question? Want to report a bug? You can ask questions and report bugs to the book authors in our official book forum here.
© 2024 Kodeco Inc.